So erhalten Sie den absoluten Wert in Excel

Nachdem Sie einige Zeit mit Excel verbracht haben, fragen Sie sich vielleicht, ob es in Excel eine Absolutwertfunktion gibt. Zum Glück gibt es. Der absolute Wert einer Zahl gibt an, wie weit sie von Null entfernt ist. Somit ist der Absolutwert immer eine positive Zahl, auch wenn der Wert negativ ist. Der Absolutwert von -7 ist beispielsweise 7. Sie brauchen also nicht wirklich eine Tabelle, um die Absolutwerte negativer Zahlen zu ermitteln. Excel kann sich jedoch als nützlich erweisen, um den Absolutwert eines Bereichs positiver und negativer Zahlen zu ermitteln. So können Sie absolute Werte für einen Datensatz bestehend aus negativen und positiven Zahlen in Excel addieren.

So erhalten Sie den absoluten Wert in Excel

Die ABS-Funktion

ABS ist die absolute Funktion, die Sie zu Excel-Tabellen hinzufügen können. Dies ist eine Funktion, die den absoluten Wert für eine Zahl in einer einzelnen Zelle zurückgibt. Es ist eine grundlegende Funktion, die keine absoluten Werte hinzufügt. Die Syntax für ABS lautet: ABS(Nummer).

Öffnen Sie als Beispiel eine leere Excel-Tabelle und geben Sie in Zelle B3 "-3454" ein. Wählen Sie dann Zelle B4 aus und drücken Sie die fx um das Fenster Funktion einfügen zu öffnen. Auswählen Alle aus dem Dropdown-Menü Oder wählen Sie eine Kategorie aus und klicken Sie auf Abs um das Fenster im Schnappschuss direkt darunter zu öffnen.

Absolutwert

Drücken Sie nun die Zellbezugstaste für das Zahlenfeld und wählen Sie B3. Drücken Sie die OK Schaltfläche, um die ABS-Funktion zur Tabellenkalkulation hinzuzufügen. Zelle B4 gibt einen Wert von 3454 zurück, wie unten gezeigt.

Absolutwert2

Mit dieser Funktion können Sie den absoluten Wert für einen Zellbereich ermitteln, indem Sie der Tabelle eine ABS-Spalte hinzufügen. Fügen Sie dann die ABS-Funktion in die Zellen der Spalte ein. Geben Sie eine =SUM-Funktion in eine Zelle am unteren Rand der Spalte ein, um die absoluten Werte hinzuzufügen.

ABS mit der SUMPRODUCT-Funktion kombinieren

Sie können ABS mit anderen Funktionen kombinieren, um den Absolutwert für positive und negative Zahlen in Excel-Tabellen zu berechnen. SUMPRODUCT ist eine der Funktionen, die ABS enthalten können, um Ihnen den absoluten Wert für einen Bereich positiver und negativer Werte zu liefern.

Geben Sie zunächst einige Dummy-Daten in Ihre Tabelle für die SUMMENPRODUKT-Funktion ein. Geben Sie die Werte „-4“, „4“ und „7“ in die Zellen A2, A3 und A4 ein. Wählen Sie Zelle A5 aus und klicken Sie in die FX-Leiste. Geben Sie dann die Funktion „=SUMMENPRODUKT(A2:A4)“ in die fx-Leiste ein und drücken Sie die Eingabetaste. Dadurch wird 7 in Zelle A5 zurückgegeben, was nicht der absolute Wert ist.

Um den absoluten Wert für den Datenbereich zu finden, müssen wir ABS in die SUMPRODUCT-Funktion einbeziehen. Ersetzen Sie also die ursprüngliche Funktion =SUMMENPRODUKT (A2:A4) durch =SUMMENPRODUKT(ABS(A2:A4)). Dann gibt A5 15 (4 + 4 + 7) für den Zellbereich zurück, wie direkt unten gezeigt.

Absolutwert3

Ermitteln Sie den Absolutwert mit SUMIF

Mit der SUMIF-Funktion können Sie Werte summieren, die ein bestimmtes Kriterium erfüllen. Daher können Sie auch den absoluten Wert für einen Zellbereich ermitteln, der zusammen mit SUMIF hinzugefügt wird. Die Syntax für SUMIF lautet: SUMIF(Bereich, Kriterien, [sum_range]).

Sie können den absoluten Wert eines Zellbereichs ermitteln, indem Sie die SUMIF-Funktion manuell in die FX-Leiste eingeben. Wählen Sie Zelle A6 aus und geben Sie '=SUMIF(A2:A4",>0″)-SUMIF(A2:A4",<0″)' in die Funktionsleiste ein. Wenn Sie dann die Eingabetaste drücken, gibt A6 den Wert 15 zurück. Die Funktion subtrahiert effektiv alle negativen Zahlen von der Summe aller positiven Werte. Sie können diese Funktion in jeder Kalkulationstabelle verwenden, indem Sie die Zellbezüge für Ihre Arbeitsblätter bearbeiten.

Absolutwert4

Die SUM-Array-Formel

Excel-Arrayformeln ermöglichen es Benutzern, mehrere Berechnungen für ein Array (oder eine Wertespalte) durchzuführen. Daher können Sie Excel auch eine SUM-Array-Formel hinzufügen, die den absoluten Wert einer Reihe von Zahlen in einer Spalte oder Zeile zurückgibt. Sie drücken Strg + Umschalt + Eingabetaste, um Tabellenkalkulationen Arrayformeln hinzuzufügen.

Die SUM-Array-Formel für absolute Werte lautet: =SUM(ABS(A2:A4)). Wählen Sie Zelle A7 in Ihrer Kalkulationstabelle aus und geben Sie "=SUM(ABS(A2:A4))" in die FX-Leiste ein. Drücken Sie jedoch nicht nur die Eingabetaste. Stattdessen sollten Sie die Tastenkombination Strg + Umschalt + Eingabetaste drücken, nachdem Sie die Formel in die FX-Leiste eingegeben haben. Dann wird die Formel mit {} geschweiften Klammern versehen, wie in der Momentaufnahme direkt unten gezeigt. Diese Matrixformel gibt auch 15 in A7 zurück, das ist der absolute Wert für die in die Zellen A2:A4 eingegebenen Daten.

absoluter Wert5

So multiplizieren Sie absolute Werte in Excel

Falls Sie einige absolute Werte in Excel multiplizieren müssen, hier eine kurze Übersicht mit den PRODUKT- und ABS-Funktionen. Geben Sie die Werte „-3“ und „3“ in die Zellen D2 und D3 ein. Wählen Sie dann in D4 fx und PRODUKT aus. Ihre Formel sollte wie folgt aussehen: PRODUKT(D2:D3).

Das Ergebnis für diese Formel ist -9, wie in Zelle D4 angezeigt.

Als nächstes wählen Sie in Zelle D5 fx und PRODUCT, dann ABS und D2: D3. Ihre Formel sollte PRODUKT(ABS(D2:D3)) lauten. Das Ergebnis für diese Gleichung ist 9, da sie die ABS-Funktion verwendet.

Es gibt also mehrere Möglichkeiten, den absoluten Wert für einen Zahlenbereich in Excel-Tabellen zu ermitteln. SUMIF, SUMPRODUCT, ABS und SUM array sind die besten Funktionen und Formeln, um absolute Werte zu erhalten. Das Kutools-Add-on für Excel enthält auch ein Vorzeichen der Werte ändern Werkzeug, das negative Zahlen in der Tabelle in positive umwandelt.